Practice Fusion Status

We are currently experiencing issues with our support ticket submittals. Please call (415) 346-7700 or (844) 903-7567 (toll free) weekdays 6am - 4:45pm PST to speak with a representative.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Nov 19, 2021 - 09:00 PST
Investigating
We are currently investigating this issue.
Posted Nov 19, 2021 - 04:31 PST