Practice Fusion Status

EHR is online but some users may experience issues with Lab results.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted May 20, 2024 - 08:43 PDT
Investigating
We are aware of an issue impacting delays in receiving lab results. We are working to resolve the issue as soon as possible.
Posted May 20, 2024 - 06:33 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).