Practice Fusion Status

Practice Fusion Login Issues
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Dec 12, 2024 - 18:34 PST
Monitoring
The Practice Fusion EHR experienced an unexpected outage at 5:30 pm PT / 8:30 ET on December 12, 2024. As soon as we became aware of the outage our team began investigating a fix to restore service as quickly as possible.
A fix has been implemented and the EHR is now fully operational.

We apologize for any inconvenience this may have caused and appreciate your patience while we worked to implement a fix. If you have any questions or experience any issues, please reach out to our support team.
Posted Dec 12, 2024 - 18:13 PST
This incident affected: Practice Fusion EHR (Login).