Practice Fusion Status

Some users may experience degraded performance or slowness while using Practice Fusion Billing Software

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 16:30 PST

Investigating

We are aware that some users are experiencing slowness when accessing Practice Fusion Billing Software. We are working to resolve the issue as soon as possible.
Posted Feb 24, 2026 - 15:30 PST
This incident affected: Practice Fusion EHR (Login, eRx, Charting, Documents, Laboratory & Radiology, Practice Fusion Billing Software, Partner Services, Schedule, Tasks, Messaging, Reports).