Practice Fusion Status

The EHR is temporarily offline for emergency maintenance

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 15:36 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 15:25 PDT

Investigating

The EHR is temporarily offline to address a critical issue. We will post updates here.
Posted Mar 17, 2026 - 15:11 PDT
This incident affected: Practice Fusion EHR (Login).