Practice Fusion Status

EHR is online but some users may experience issues with Immunizations

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 10:03 PST

Investigating

We are aware of an issue impacting the Immunizations section. We are working to resolve the issue as soon as possible.
Posted Feb 17, 2025 - 09:30 PST
This incident affected: Practice Fusion EHR (Charting).