Practice Fusion Status

EHR is online but some users may experience issues with ID.me and sending Controlled Substances
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 14:03 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2024 - 08:01 PST
Identified
The issue has been identified by ID.me and a fix is being implemented.
Posted Nov 18, 2024 - 07:43 PST
This incident affected: Practice Fusion EHR (eRx).