Practice Fusion Status

Practice Fusion Billing Software issue

Incident Report for Practice Fusion

Resolved

The fix has been implemented for the issue impacting Practice Fusion Billing Software. Subsequent testing has proven successful. Thank you for your patience.
Please log a ticket with Veradigm Support if you continue to experience an issue.
Posted Oct 20, 2025 - 14:12 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 12:06 PDT

Identified

The issue has been identified, and we are working on implementing a fix.
Posted Oct 20, 2025 - 11:01 PDT

Update

We are continuing to investigate the login issue.
Posted Oct 20, 2025 - 10:19 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 09:23 PDT

Investigating

We are experiencing an issue with the Practice Fusion Billing Software and are actively troubleshooting.
Posted Oct 20, 2025 - 09:14 PDT
This incident affected: Practice Fusion EHR (Practice Fusion Billing Software).