Practice Fusion Status

EHR is online but some users may experience issues with insurance eligibility checks
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jun 09, 2023 - 09:56 PDT
Update
Practice Fusion's partner for insurance eligibility checks is continuing to troubleshoot the issue. They do not have an ETA for restoration of service at this time. They have advised to plan for access to be unavailable through tomorrow (June 9) morning.
Posted Jun 08, 2023 - 16:46 PDT
Identified
Practice Fusion's partner service for insurance eligibility checks has confirmed that they are currently experiencing network issues that are significantly impacting application availability. They are working to restore service but do not currently have an ETA.
Posted Jun 08, 2023 - 12:07 PDT
Investigating
We are aware of an issue impacting insurance eligibility checks and we are currently investigating the root cause.
Posted Jun 08, 2023 - 10:06 PDT
This incident affected: Practice Fusion EHR (Partner Services).