Practice Fusion Status

EHR is online but some users may experience delays with Superbill submissions

Incident Report for Practice Fusion

Resolved

Superbill submissions that were previously delayed are no longer delayed for CollaborateMD. All submissions have been transmitted successfully.
Posted Jun 20, 2023 - 05:39 PDT

Identified

Superbill submissions that were previously delayed are no longer delayed for all billing partners except CollaborateMD. We have reached out to CollaborateMD to identify and resolve the remaining issue as soon as possible.
Posted Jun 19, 2023 - 17:53 PDT

Investigating

We are investigating an issue that is causing delays when submitting superbills to billing partners.
Posted Jun 19, 2023 - 15:35 PDT
This incident affected: Practice Fusion EHR (Partner Services).