Practice Fusion Status

EHR Login Issue
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Dec 11, 2023 - 08:28 PST
Monitoring
A fix has been implemented. Users should be able to log in to the EHR. We will continue to monitor performance.
Posted Dec 11, 2023 - 07:50 PST
Investigating
Currently, we are investigating an issue with login. Some users will not be able to access the EHR.
Posted Dec 11, 2023 - 07:30 PST
This incident affected: Practice Fusion EHR (Login).