Practice Fusion Status

EHR is online but some users may experience issues with Bioreference Lab delays.

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 13:00 PDT

Identified

We are aware of an issue impacting Lab orders and results causing delays with our partner Bioreference. They have made us aware and are working to resolve the issue as soon as possible.
Posted Mar 10, 2025 - 12:38 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).