Practice Fusion Status

EHR is online but some users may experience issues with Lab ordering
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jun 12, 2023 - 22:15 PDT
Monitoring
We have implemented a fix for the issue. Please be aware that lab orders may be delayed through the remainder of the day.
Posted Jun 12, 2023 - 14:19 PDT
Identified
We are aware of an issue causing delays with Lab ordering. We have identified the cause and are working to resolve the issue as soon as possible.
Posted Jun 12, 2023 - 09:31 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).