Practice Fusion Status

The EHR is temporarily offline for scheduled maintenance
Incident Report for Practice Fusion
Resolved
Scheduled maintenance is complete.
Posted Sep 14, 2023 - 23:25 PDT
Monitoring
We are undergoing scheduled maintenance.
Posted Sep 14, 2023 - 23:21 PDT
This incident affected: Practice Fusion EHR (Login, eRx, Charting, Documents, Laboratory & Radiology, Partner Services, Schedule, Tasks, Messaging, Reports) and Patient Fusion PHR.