Practice Fusion Status

EHR is online but some users may experience issues with Billing submissions to Kareo
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 08:34 PST
Investigating
We are aware of an issue impacting billing submissions to Kareo. We are working with our partner to resolve the issue as soon as possible.
Posted Nov 21, 2022 - 19:14 PST
This incident affected: Practice Fusion EHR (Partner Services).