Practice Fusion Status

EHR is online but some users may experience issues with Quest lab ordering
Incident Report for Practice Fusion
Resolved
This incident has been resolved. Please note that there may still be a delay in lab orders reaching the lab as our system processes the backup of orders.
Posted Mar 06, 2023 - 14:16 PST
Monitoring
A fix has been implemented and we are monitoring the results. Please note that there may be a delay in lab orders reaching the lab as our system attempts to process the backup of orders.
Posted Mar 06, 2023 - 12:48 PST
Identified
Quest Labs has identified the issue on their end and is working on a fix. Lab orders sent to Quest may fail until the fix has been implemented. We will provide an update here once Quest has confirmed a resolution.
Posted Mar 06, 2023 - 10:19 PST
Investigating
We are aware of an issue impacting Quest lab ordering. We are working with Quest to determine the root cause of the issue as soon as possible.
Posted Mar 06, 2023 - 10:03 PST
This incident affected: Practice Fusion EHR (Laboratory & Radiology).