Practice Fusion Status

The EHR is offline temporarily
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Aug 20, 2024 - 12:28 PDT
Monitoring
The EHR is back online. A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2024 - 11:52 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 20, 2024 - 11:33 PDT
Investigating
We are currently experiencing a system wide outage. We are working to resolve the issue and will post updates here as they become available.
Posted Aug 20, 2024 - 11:19 PDT
This incident affected: Practice Fusion EHR (Login).