Practice Fusion Status

EHR is online but some users may experience slowness

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 09:22 PST

Update

We are continuing to monitor for any further issues.
Posted Feb 20, 2025 - 09:16 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2025 - 09:05 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 20, 2025 - 08:54 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 20, 2025 - 08:34 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 20, 2025 - 08:31 PST

Investigating

We are aware that some users are experiencing slowness when accessing some features of the EHR. We are working to resolve the issue as soon as possible.
Posted Feb 20, 2025 - 08:20 PST