Practice Fusion Status

EHR is online but some users may experience delays in receiving lab results.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 16:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 04, 2024 - 15:39 PDT
Investigating
We are aware of an issue impacting lab results with LabCorp. We are working with the vendor to resolve the issue as soon as possible.
Posted Jun 04, 2024 - 12:34 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).