Practice Fusion Status

EHR is online but some users may experience issues logging in.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Sep 08, 2020 - 07:32 PDT
Update
We are continuing to investigate this issue.
Posted Sep 08, 2020 - 07:03 PDT
Investigating
We are currently investigating this issue.
Posted Sep 08, 2020 - 06:58 PDT