Practice Fusion Status

Drug Search Not Available
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jan 01, 2021 - 08:20 PST
Update
We are continuing to monitor for any further issues.
Posted Dec 28, 2020 - 08:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 28, 2020 - 08:58 PST
Investigating
We are currently investigating this issue.
Posted Dec 28, 2020 - 08:40 PST
This incident affected: Practice Fusion EHR (eRx).