Practice Fusion Status

The EHR is online but some users may experience issues accessing the Patient Ledger billing feature

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 18:13 PST

Identified

We are aware of an issue impacting the Patient Ledger billing feature. We have identified root cause and are preparing to deploy a fix on Friday, March 7th.
Posted Mar 06, 2025 - 18:44 PST
This incident affected: Practice Fusion EHR (Reports).