Practice Fusion Status

Phone System Outage

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 16:37 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 15, 2025 - 15:02 PDT

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 14:37 PDT

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 12:40 PDT

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 10:45 PDT

Investigating

We’re currently experiencing an issue with our phone system, and inbound/outbound calls may not be working at this time. Our team is working with our phone provider to restore service as quickly as possible.

Please visit help.practicefusion.com to start a live chat or create a support case for immediate assistance.
Posted Oct 15, 2025 - 09:55 PDT