Practice Fusion Status

EHR is online but some users may experience issues with Lab ordering

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Sep 25, 2024 - 16:58 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 25, 2024 - 16:44 PDT

Investigating

We are aware of an issue impacting Lab ordering. We are working to resolve the issue as soon as possible.
Posted Sep 25, 2024 - 16:32 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).