Practice Fusion Status

EHR is online but some users may experience issues accessing various areas of the EHR.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted May 22, 2024 - 13:54 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 22, 2024 - 12:50 PDT
Update
We are continuing to investigate this issue.
Posted May 22, 2024 - 10:53 PDT
Investigating
We are aware of an issue impacting accessing various areas of the EHR.
Posted May 22, 2024 - 10:50 PDT
This incident affected: Practice Fusion EHR (Login).