Practice Fusion Status

EHR is online but some users may experience delays with Superbill submissions.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 18:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 21, 2021 - 14:48 PDT
Investigating
We are aware of an issue impacting Superbill submissions. Superbills are submitting but may be slow to do so. We are working to resolve the issue as soon as possible.
Posted Oct 21, 2021 - 12:31 PDT
This incident affected: Practice Fusion EHR (Partner Services).