Practice Fusion Status

EHR is online but some users may experience issues with insurance Eligibility Checks
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 10:47 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2023 - 10:29 PST
Investigating
We are aware of an issue impacting insurance eligibility checks. We are working to resolve the issue as soon as possible.
Posted Mar 03, 2023 - 07:58 PST
This incident affected: Practice Fusion EHR (Partner Services).