Practice Fusion Status

The EHR is offline
Incident Report for Practice Fusion
Resolved
The issue is resolved.
Posted May 18, 2024 - 07:30 PDT
Monitoring
The issue is resolved.
Posted May 18, 2024 - 07:28 PDT
Investigating
We are currently investigating this issue.
Posted May 18, 2024 - 06:25 PDT
This incident affected: Practice Fusion EHR (Login).