Practice Fusion Status

Practice Fusion log in issues

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Sep 28, 2022 - 13:54 PDT

Investigating

We are aware that some users are experiencing issues related to text receipt of codes for log in or prescribing. Please select the "voice" option which seems to be working instead.
Posted Sep 28, 2022 - 11:58 PDT
This incident affected: Practice Fusion EHR (Login).