Practice Fusion Status

EHR is online but some users may experience issues with e-prescribing controlled substances
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted May 10, 2024 - 11:46 PDT
Monitoring
Id.me has implemented a fix and we are monitoring the results.
Posted May 10, 2024 - 10:59 PDT
Investigating
We are aware of an issue while authenticating with ID.me for e-prescribing controlled substances. We are working to resolve the issue as soon as possible.
Posted May 10, 2024 - 09:51 PDT
This incident affected: Practice Fusion EHR (eRx).