Practice Fusion Status

EHR is online but some users may experience issues with Integrated Scanning.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted May 22, 2024 - 12:51 PDT
Identified
We are aware of an issue impacting our Integrated Scanning feature. We are working with our partner Dynamsoft to resolve the issue as soon as possible.
Posted May 22, 2024 - 05:56 PDT
This incident affected: Practice Fusion EHR (Documents).