Practice Fusion Status

EHR is online but some users may experience issues with Lab ordering
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Feb 21, 2023 - 15:08 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2023 - 14:50 PST
Update
Some lab ordering is still being impacted by an intermittent issue. We are continuing to investigate all possible causes.
Posted Feb 21, 2023 - 13:35 PST
Update
We are continuing to investigate intermittent issues with lab ordering.
Posted Feb 21, 2023 - 11:11 PST
Investigating
We are aware of an issue impacting Lab ordering. We are working to resolve the issue as soon as possible.
Posted Feb 21, 2023 - 09:04 PST
This incident affected: Practice Fusion EHR (Laboratory & Radiology).