Practice Fusion Status

EHR is online but some users may experience issues with ordering labs from Quest
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jan 18, 2022 - 10:35 PST
Investigating
We are aware of an issue impacting Lab ordering. We are working to resolve the issue as soon as possible.
Posted Jan 18, 2022 - 06:30 PST
This incident affected: Practice Fusion EHR (Laboratory & Radiology).