Practice Fusion Status

EHR is online but some administrators may experience issues within the Subscription section.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jul 03, 2024 - 11:37 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2024 - 09:41 PDT
Update
We are continuing to investigate this issue.
Posted Jul 03, 2024 - 08:27 PDT
Investigating
We are aware of an issue impacting the ability to manage your Subscription. We are working with our partner Zuora to resolve the issue as soon as possible.
Posted Jul 03, 2024 - 07:39 PDT
This incident affected: Practice Fusion EHR (Partner Services).