Practice Fusion Status

EHR is online but some users may experience issues with Documents management
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Jul 14, 2022 - 14:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2022 - 13:09 PDT
Update
We are continuing to investigate this issue.
Posted Jul 14, 2022 - 12:03 PDT
Investigating
We are aware of an issue impacting Documents management. We are working to resolve the issue as soon as possible. There may be impacts with referrals, faxing and telehealth.
Posted Jul 14, 2022 - 11:00 PDT
This incident affected: Practice Fusion EHR (Documents).