Practice Fusion Status

EHR is online but some users may experience delay issues with Quest Lab ordering
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Mar 30, 2023 - 12:07 PDT
Monitoring
We are not seeing any new errors impacting Quest Lab ordering at this time. We will continue to monitor the system while we await confirmation of a resolution from Quest.
Posted Mar 30, 2023 - 10:10 PDT
Investigating
We are aware of an issue impacting delays with Quest Lab ordering. We are working to resolve the issue as soon as possible.
Posted Mar 30, 2023 - 09:09 PDT
This incident affected: Practice Fusion EHR (Laboratory & Radiology).