Practice Fusion Status

EHR is online but some users may experiencing performance issues.

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 14:34 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 14:05 PDT

Investigating

We are currently investigating this issue.
Posted Oct 20, 2025 - 12:25 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 10:02 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:42 PDT

Investigating

The Amazon Web Services (AWS) outage is causing slowness or unexpected behavior in Practice Fusion and Patient Fusion for some users. Some third-party integrated services may also be impacted.

Our support team is also currently experiencing issues with phone systems and chat due to the AWS outage. Please visit help.practicefusion.com to create a support case for immediate assistance. Our team is actively monitoring the situation and working to resolve it as quickly as possible.
Posted Oct 20, 2025 - 08:21 PDT