Practice Fusion Status

EHR is online but some users have reported login issues with the Patient Fusion PHR.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted May 19, 2020 - 06:40 PDT
Investigating
We are aware that some users are unable to log in to the PHR. We are working to resolve the issue and will post updates here as they become available.
Posted May 18, 2020 - 15:56 PDT
This incident affected: Patient Fusion PHR.