Practice Fusion Status

EHR is online but some users may experience issues with Flowsheets and Observations.
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Nov 06, 2020 - 04:20 PST
Investigating
We are currently investigating this issue.
Posted Nov 06, 2020 - 04:09 PST