Practice Fusion Status

EHR is online but some users may experience issues with viewing documents

Incident Report for Practice Fusion

Resolved

This incident has been resolved. If you are still experiencing issues, please log out and back in to resolve the issue.
Posted Jun 11, 2026 - 08:31 PDT

Monitoring

A fix has been implemented and we are monitoring the results. If you are still experiencing issues, please log out and back in to resolve the issue.
Posted Jun 11, 2026 - 08:27 PDT

Identified

The issue has been identified and a fix is being implemented. If you are still experiencing issues, please log out and back in to resolve the issue.
Posted Jun 11, 2026 - 08:12 PDT

Investigating

We are currently investigating this issue.
Posted Jun 11, 2026 - 06:34 PDT
This incident affected: Practice Fusion EHR (Documents).