Practice Fusion Status

The EHR is online but some users may experience issues with Scheduling

Incident Report for Practice Fusion

Resolved

This incident has been resolved.
Posted Feb 20, 2026 - 13:20 PST

Monitoring

We are aware of an issue impacting a very small number of customers loading their schedule. To see appointments for the day, please use the "Appointment and eligibility report" under the Reports tab in order to generate a list of the appointments.
Posted Feb 20, 2026 - 09:09 PST

Investigating

We are aware of an issue impacting Scheduling. We are working to resolve the issue as soon as possible.
Posted Feb 20, 2026 - 08:46 PST
This incident affected: Practice Fusion EHR (Schedule).