Practice Fusion Status

EHR is online but some users may experience issues with Schedule Management
Incident Report for Practice Fusion
Resolved
This incident has been resolved.
Posted Mar 05, 2021 - 09:51 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2021 - 08:09 PST
Investigating
We are aware of an issue impacting Schedule management. We are working to resolve the issue as soon as possible.
Posted Mar 05, 2021 - 07:47 PST