Practice Fusion Status

Practice Fusion log in issues
Incident Report for Practice Fusion
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2022 - 16:13 PST
Investigating
We are aware that some users are unable to log in to the EHR. We are working to resolve the issue and will post updates here as they become available. Choosing to receive your code via VOICE is available.
Posted Jan 14, 2022 - 09:03 PST
This incident affects: Practice Fusion EHR (Login).