Practice Fusion Status

The EHR is online but some users may experience issues with insurance eligibility checks

Incident Report for Practice Fusion

Resolved

This incident has been resolved and eligibility checks have been restored for all payers.
Posted Feb 17, 2025 - 12:51 PST

Update

We are continuing to work on a fix for this issue.
Posted Sep 10, 2024 - 07:39 PDT

Identified

Eligibility checks for certain payers are not available in Practice Fusion because Change Healthcare (CHC) continues to experience service interruptions due to a cyberattack. We are working with CHC and will provide updates as eligibility checks for these payers become available.
Posted Aug 08, 2024 - 08:36 PDT
This incident affected: Practice Fusion EHR (Partner Services).